Exa Networks - SurfProtect Problems – Incident details

All systems operational

SurfProtect Problems

Resolved
Operational
Started over 3 years agoLasted 8 minutes
Updates
  • Resolved
    Resolved

    All services have been restored, if you are still having issues please call us on 0345 145 1234 or email via helpdesk@exa.net.uk

  • Investigating
    Investigating

    Following the maintenance, we have noticed an issue with some of the SurfProtect servers. Affected customers will have no access to the internet, our Service engineers are investigating this. As soon as we have an update we will update this status.