Exa Networks - Exa Office Phone System – Incident details
All systems operational
Exa Office Phone System
Resolved
Operational
Started about 4 years agoMay 27, 2022Lasted about 2 hoursMay 27, 20227:259:13 AMUTC
Updates
Resolved
UTC
Resolved
UTC
The incident has been resolved
Update
UTC
Update
UTC
The phone system is working now. We will continue monitoring this.
Investigating
UTC
Investigating
UTC
We have identified a problem with our phone system this morning. The calls are going to voicemail so could you please email helpdesk@exa.net.uk with any support queries, our team will get back to you as soon as they can.