Firefox Version 81.0 incompatibility Tuesday 29th September 2020 10:31:43


The most recent update to the Firefox web browser (Version 81.0) has been identified as not compatible with SurfProtect.

We are investigating the cause of the incompatibility and will endeavour to rectify this at our earliest opportunity.

In the meantime, please consider using an alternative browser.

The compatibility issues with the latest Firefox web browser update (Version 81.0) and SurfProtect have now been resolved. Apologies for any inconvenience caused.