Prolonged Fibre Maintenance - Leeds Monday 13th July 2020 10:58:19


Maintenance by our fibre partners in Leeds appears to be causing some disruption still to a small number of lines this morning.

We are investigating this and will update again by 11:30

All cabling work has now been completed and we have all customers, bar one, back online. We are in contact with the final customer and we are closing this incident down.

Apologies for the disruptions, we have escalated this matter with our partners.

We have been informed that services should be re-established by the end of the day.

We again apologise for this issue and are doing everything we can to get our customers back online.

UPDATE All services are expected to be back online by 13:30 today.

If you continue to experience any issues please contact our Technical Support team.

UPDATE 14th July 10:30

We are still experiencing some disruption, affected customers have been informed