Network Stability - DDos Attack Thursday 26th September 2019 08:08:00


One of our customer has been targeted by a large Denial of Service Attack this morning. It is affecting our network.

We are mitigating the issue and will provide an update shortly.

Update: 08:10: the mitigation is under way, service is improving but not fully restored

Update: 08:15: the attack is saturating many 10Gbps link of both peering and transit

Update: 08:20: customers should now able to use the net, performance may be affected while the DDOS continues

Update: 08:25: we are still seeing over 10Gbps of DDOS traffic incoming on each of our peering links in London

Update: 08:40: the DDOS is still ongoing

Update: 09:25: the attackers is using DNS amplification. Google DNS is currently the largest source of traffic, all traffic to Google may therefore be affected but other destination have been mitigated

Update: 10:10: At 09:45 Google changed how their traffic is reaching us and it may therefore affect other destination. The level of traffic is however lower and not affecting as many destinations.

Update: 14:00: The DDOS mitigation remain in place as we continue to see short attacks directed at the target customer

Since the last update, we have not seen any further DDoS attempts and traffic has returned to normal.