Exa Networks - Surfprotect Quantum – Incident details

All systems operational

Surfprotect Quantum

Resolved
Operational
Started almost 2 years agoLasted 16 minutes
Updates
  • Resolved
    Resolved

    Our services team successfully identified and resolved the issue that affected some of our customers. We sincerely apologise for any inconvenience this may have caused and appreciate your patience during this time. Should you continue to experience any difficulties or have any concerns, please contact our Support team for further assistance.

  • Investigating
    Investigating

    We are aware a number of our customers using Surfprotect Quantum are currently facing issues accessing internet services. Our services team are investigating this as we speak and we will provide updates as soon as we have them available. We appreciate your patience and understanding in this matter.