Exa Networks - Support Line Call Routing – Incident details
All systems operational
Support Line Call Routing
Resolved
Operational
Started over 2 years agoLasted 7 days
Updates
Resolved
Resolved
The call routing issue has now been resolved. All calls should now be answered as normal.
Investigating
Investigating
We are currently investigating an issue with our Support phone line where calls are intermittently misrouted. Calls will still be answered but we may need to give you a callback.