Scheduled for February 18, 2026 at 2:58 PM – 3:03 PM
Affects
Updates
Completed
February 18, 2026 at 3:03 PM
Completed
February 18, 2026 at 3:03 PM
Maintenance has completed successfully
In progress
February 18, 2026 at 2:58 PM
In progress
February 18, 2026 at 2:58 PM
Maintenance is now in progress
Planned
February 18, 2026 at 2:58 PM
Planned
February 18, 2026 at 2:58 PM
This is one of our two weekly maintenance update slots.
During these windows, we will carry out any essential maintenance to ensure our systems are fully up to date and can keep on providing you with exceptional service.
At times, we may need to reboot some of our hardware to carry out the updates, so customers may experience intermittent connectivity with some of our services during these periods.